Archives

dmc_lat47

vm (copied to new host) has no network connectivity

The problem:

Yesterday we had a power outage.

Fried the system disk (c:) on the host machine.

I had configured all the virtual drives and virtual machines on a second, data disk (d:); thankfully this survived.

Everything was working fine prior to the incident.

I popped in a new c: drive, and re-installed server 2012 r2, and added hyper-v.

created a new machine, using the old drives, and hooray, the vm booted with all the software intact.

*however!* the vm doesn’t have internet access, nor can it be pinged.

Salient Details

Once again everything was working prior to the power outage.

I have two physical nics (nic1 nic2) in the box.  Nic1 is dedicated to the host, and it’s ip is statically allocated (192.168.1.25). Nic2 is supposed to be dedicated to the vm, and I didn’t bother assigning an IP to it. Both are connected to the network.

When I first added the Hyper-V role though Server Manager, I noticed that the server name/ip it came up with was ServerName/[dynamically allocated IP of nic2]; that is, hyper-V seemed to be wanting to configure the server with nic2, rather than nic1. 
Is this right?  There was no option to select ‘ServerName/[nic1 IP]

In HyperV after the reboot, I created a virtual switch with nic 2.  Then I created a new VM, but used the vhx file which was on the surviving physical D: drive.  I attached the virtual switch tp the new VM.

The VM booted.  All the files were there.  However, the network icon in the system tray always indicates ‘Unidentified network/limited’ under ‘Connections’

What I’ve Tried:

I found i had to reset the ipv4 static ip on the new virtual machine, as well as the dns host specification.

I tried removing the HyperV role, disabling nic2, and re-adding the HyperV role.  This time the server it came up with was ServerName/[NIC1 IP].  Then re-enabled nic2, used it to create a virtual switch, and attached that to yet another created
VM.

My next try, as a diagnostic, is to create a completely new VM with a new install of the OS.  I’m doing this as a diagnostic, but forsaking the old disks has pretty unpleasant implications.

It’s got to be something simple!  Any help would be truly appreciated.

thanks in advance


dmc_lat47

Read full post . . . .

Go Que Newsroom Categories

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 36 bytes) in /home/content/36/8658336/html/goquecom/wp-includes/taxonomy.php on line 3363